Instability affecting ID CLOUD capabilities

Incident Report for unico

Resolved

Executive Summary and Impact

On July 13, 2026, we identified an instability in our identity verification capability, generating errors on a minimal portion of IDCloud requests, affecting multiple authentication flows. The issue was detected through automated availability alerts around 9:27 AM BRT, with a slight increase in errors already noticeable from approximately 8:00 AM BRT and a significant worsening starting around 9:07 AM BRT, reaching peak impact around 9:49 AM BRT.

Root Cause and Resolution

The root cause was identified as a gradual change applied to an internal authentication component, which caused a failure in session token signature validation. Once the root cause was confirmed, the engineering team reverted the change, and service availability returned to normal. The most critical phase of the impact lasted approximately 44 minutes.

Commitment and Next Steps

Engineering is evaluating improvements to the change-validation process for gradual rollouts affecting critical authentication components, including automatic rollback mechanisms in case of error spikes during this type of rollout. A detailed postmortem is expected to be shared internally as a next step.
Posted Jul 13, 2026 - 10:47 GMT-03:00

Monitoring

Dear Client,

Our engineering team has identified and implemented the actions to resolve the instability in the identity verification capability that was generating an error in a small portion of IDCloud requests.
At this time, the technical team is conducting detailed analysis in our data layer and continues to monitor the environment.

We reinforce that further updates will be sent shortly.
Posted Jul 13, 2026 - 10:06 GMT-03:00

Identified

Dear Client,

We have identified an instability in the identity verification capability, generating an error in a small portion of IDCloud requests.
Our engineering team is already mobilized for diagnosis and working to identify the root cause in order to normalize the service as soon as possible. At this time, the technical team is conducting detailed analysis in our data layer to mitigate the impact.

We reinforce that further updates will be sent shortly.
Posted Jul 13, 2026 - 09:30 GMT-03:00
This incident affected: IDCloud | Risk Score (API), IDCloud | Identity Verification (API), and IDCloud - Web Journey (API).