Instability affecting ID CLOUD capabilities

Incident Report for unico

Resolved

Executive Summary and Impact

Around 5:08 PM, an automated alert detected an availability drop in the facial recognition service (1:N flow), triggering the incident. The issue escalated quickly and began affecting the behavior alerting service and, subsequently, the process creation flow, due to cascading timeouts between these services. The impact affected a subset of clients using these capabilities. The situation was reported as stabilized at 5:22 PM, with metrics returning to normal levels.

Root Cause and Resolution

The root cause was a traffic spike generated by an internal workload, which sent a high volume of facial recognition requests directly into the biometric pipeline, bypassing the edge layer used by normal client traffic. This additional volume saturated the capacity of the database supporting the facial recognition service. The saturation caused timeouts in that service, which cascaded to the biometric engine orchestration service, then to the behavior alerting service, and finally to the process creation flow using these capabilities.

To resolve the issue, the team stopped the workload responsible for the spike and increased the capacity of the affected database. These actions mitigated the problem, with error volume returning to near-zero levels.

Commitment and Next Steps

A follow-up item was opened to implement rate limiting for the type of internal workload that caused the spike, as a preventive measure against recurrence. The capacity increase for the affected database was already carried out during the incident itself.
Posted Aug 10, 2026 - 18:01 GMT-03:00

Monitoring

Our engineering team has identified and implemented the necessary actions to resolve the instability in the affected IDCloud flow capabilities.

At this time, the technical team is conducting a detailed analysis of our data layer and continues to monitor the environment.

We reiterate that further updates will be sent shortly.
Posted Aug 10, 2026 - 17:25 GMT-03:00

Identified

Dear customer,

We have detected an impact on some IDCloud requests, affecting Behavior Alert (IDTrust) capability and the 1:N flow. This instability may also affect customers in Mexico who use this capability.

Our engineering team is mobilized to resolve the issue as soon as possible.
We will provide new updates shortly.
Posted Aug 10, 2026 - 17:10 GMT-03:00
This incident affected: IDCloud | Identity Verification (API), ID Cloud | Fraud Risk Classification (IDTrust | API), and IDCloud - Web Journey (API).