Instability affecting ID CLOUD capabilities

Incident Report for unico

Resolved

Executive Summary and Impact
On July 21, 2026, at around 11:17 AM BRT, a drop in availability was detected in the IDCloud create-process and process-query flows. During the impact window, a portion of customers experienced elevated latency and failures (timeouts) in these operations, which propagated through the chain of dependent services. The effective impact was concentrated in a window of approximately 23 minutes. At peak, error and latency indicators were above normal operating levels.

Root Cause and Resolution
The investigation pointed to the degradation of a read database (replica) supporting these capabilities as the origin. This database began to show increased load and query execution time, with internal contention that stalled processing and backed up read requests. As a result, the services above it started accumulating timeouts and triggering protection mechanisms (circuit breakers), producing the cascading effect experienced by customers.

Commitment and Next Steps
Unico is handling this incident with a detailed postmortem, already being drafted, and will hold a post-incident review (PiR) meeting to consolidate preventive actions. Among the follow-ups already raised during the response are the preparation of diagnostic routines and queries to speed up the identification of contention in this database layer, and improved observability over the databases involved. The detailed preventive actions will be shared in the postmortem.

We reaffirm our commitment to the stability and reliability of the platform and apologize for the inconvenience caused during the period of instability.

Unico Team.
Posted Jul 21, 2026 - 13:00 GMT-03:00

Monitoring

Dear Customer,

Our engineering team has identified and implemented the necessary actions to resolve the instability in the affected IDCloud flow capabilities.

At this time, the technical team is conducting a detailed analysis of our data layer and continues to monitor the environment.

We reiterate that further updates will be sent shortly.
Posted Jul 21, 2026 - 11:50 GMT-03:00

Update

We are continuing to work on a fix for this issue.
Posted Jul 21, 2026 - 11:46 GMT-03:00

Identified

Dear customer,

We are investigating an instability in our IDCloud capabilities, affecting the process creation and process details flows. Our engineering team is mobilized to resolve the issue as soon as possible. We will provide further updates shortly.
Posted Jul 21, 2026 - 11:30 GMT-03:00
This incident affected: IDCloud | Risk Score (API), Card Not Present (ID Pay - Brazil) (API), IDCloud | Identity Verification (API), ID Cloud | Fraud Risk Classification (IDTrust | API), and IDCloud - Web Journey (API).