Instability in Authentication Services for the UnicoPeople Portals and IDCloud messaging service

Incident Report for unico

Resolved

Executive Summary and Impact

At 10:51 AM on 07/16/2026, an issue was identified in the authentication service on the Unico People admission portal and in messaging, which affected the delivery of SMS and email links to Unico People and IDCloud clients, as well as B2C client authentication on the Unico People admission portal. The impact was limited to these two flows and did not affect the product's core critical journey. The incident lasted approximately 30 minutes until full resolution.

Root Cause and Resolution
The root cause was identified as storage pressure on one node of the messaging cluster, which reached a critical disk threshold, degrading the processing of queues responsible for message delivery and authentication. The engineering team increased the cluster's storage capacity at approximately 10:59 AM, which allowed queues and monitoring indicators to normalize within minutes. The environment was monitored until full recovery was confirmed, and the incident was closed at 11:20 AM.

Commitment and Next Steps
The engineering team will review alert escalation and prioritization criteria for this type of degradation, since the alerts correctly identified the issue, but the automatic escalation flow to the responsible team can be improved. A detailed postmortem is being prepared and will be shared in the coming days.
Posted Jul 16, 2026 - 12:28 GMT-03:00

Monitoring

Dear Customer,

Our team identified the issue and took action to resolve the incident. We experienced an instability in our authentication system for the Unico People portals, as well as issues in our messaging service affecting customers in the IDCloud flow, for SMS and email delivery.

Our engineering team remains mobilized, monitoring the environment to ensure it continues functioning properly.
Posted Jul 16, 2026 - 11:08 GMT-03:00

Investigating

Dear Customer,

We are investigating an instability in our authentication system for the Unico People portals and are also assessing issues in our messaging service affecting IDCloud customers.

Our engineering team is mobilized to resolve the issue as soon as possible. We will provide updates shortly.
Posted Jul 16, 2026 - 11:02 GMT-03:00
This incident affected: IDCloud - Web Journey (Messaging System) and Unico People (Notificações, Módulo Candidato).